MEG Processor

Main Frame Guide (waveform Analyses)
DISCLAIMER

We have used reasonable effort to include accurate and up-to-date information in this manual; it does not, however, make any warranties, conditions or representations as to its accuracy or completeness. We assume no liability or responsibility for any errors or omissions in the content of this manual. Your use of this manual is at your own risk. Under no circumstances and under no legal theory shall the authors be liable for any indirect, direct, special, incidental, punitive, exemplary, aggravated or consequential damages arising from your use of this manual.

Features and specifications of this software program are subject to change without notice. This manual contains information and images about MEG Processor, its user interface, GUI and its other signal processing algorithms, publications that are protected by copyright.

All rights reserved. This publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, recording, or otherwise, with prior permission by the authors.

Sending Your Comments and Critiques: We’d like to hear from you. Your comments and suggestions for improving this document are welcome and appreciated. Please e-mail your feedback to MEG_Processor@live.com

Thank you.
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>MEG/EEG Waveform Mark</td>
<td>21</td>
</tr>
<tr>
<td>Waveform Segments</td>
<td>22</td>
</tr>
<tr>
<td>Classifying a Data Segment as “Bad”</td>
<td>22</td>
</tr>
<tr>
<td>Select-Cut</td>
<td>24</td>
</tr>
<tr>
<td>Pattern Template Matching</td>
<td>26</td>
</tr>
<tr>
<td>Threshold Detection</td>
<td>29</td>
</tr>
<tr>
<td>MEG/EEG Montages (CxC)</td>
<td>32</td>
</tr>
<tr>
<td>Single/Multi-Wave (or Channel) Viewer</td>
<td>34</td>
</tr>
</tbody>
</table>
Warnings and Cautions

This software supports both magnetoencephalography (MEG) and electroencephalography (EEG) data. Though MEG and EEG waveforms appear similar, they have different unit in amplitude. If the MEG and EEG data recorded simultaneously, their time unit or temporal resolution is typically the same.

Modern MEG/EEG systems typically have MEG/EEG sensor/electrode channels as well as other channels. For example, trigger channel, head-localization channels and additional ADC (analog-to-digital) channels. To avoid problems, please pay attention to the channel names and the amplitude value/unit. Their values may be of different orders of magnitude. Unexpected results may occur if their values are mixed in measurements.

When performing waveform analysis, regardless of whether MEG or EEG or both are displayed, ensure that the data are appropriately filtered with DC-offset/linear-trend removal. If the waveforms had very large amplitude (e.g. > 3 pt), it is recommended that you identify possible noise.

There are a set of source localization algorithms in the program. Each source localization algorithm has been designed and tested for specific reasons. To ensure the quality and visibility, all source localization algorithms will generate a volumetric source image, which can be considered as an image with millions of “dipoles” or multi-value-voxel, which is significantly different from the conventional magnetic source imaging (MSI) or equivalent current dipoles.

Head movement during MEG recordings may affect the accuracy of source imaging. If subjects move too much during MEG recordings, the MEG results are more than likely poor.

The accuracy of the structural images (MRI/CT) may also affect the MEG results if the conventional magnetic source imaging (MSI) is used. If MRI/CT is distorted, the combination of MEG/MRI/CT will be low-quality. In addition, multiple local sphere, head model or other structural constrained source localization may internally use the MRI/CT images. Any analysis based on those distorted images may yield unexpected or poor results.

The following warnings and cautions appear in this guide. Please ensure you are aware of all the operations and interpretations.
Preface

The Main Frame is one of the core windows of MEG Processor software. It is used as the primary tool to view MEG, EEG, triggers and other data, mark and classify the data, and identify results of interest for academic or clinical purposes. Importantly, the Main Frame provides graphic user interface (GUI) for access other function. In other words, it is also often used to launch other windows such as source localization.

This guide describes the operation of the MEG Processor application for MEG/EEG. Though there are many functions related to MRI/CT, analyses of MRI/CT are not the focuses of this guide.

Determining the Software Version
In the Main Frame: select Help -> About.
The About Dialog will show the version of the software.

Intended Audience
This guide is intended for anyone needing to view or edit data collected using a MEG/EEG system. It assumes the reader is familiar with standard MEG/EEG procedures and with the Windows operating systems.

Document Structure
Documents are generally provided in both Microsoft Word® format and Adobe® Acrobat® PDF (Portable Document Format). All editions are distributed on Flash Driver, CD or websites with the related software, and include bookmarks and hyperlinks to assist navigating the document. Please feel free to send your critiques, corrections, suggestions and comments to MEG_Processor@live.com.

Conventions
Numeric: Numeric values are generally presented in decimal but in special circumstances may also be expressed in hexadecimal or binary. Hexadecimal values are shown with a prefix of 0x, in the form 0x3D. Binary values are shown with a prefix of 0b, in the form 0b00111101. Otherwise, values are presumed decimal.

Units: Units of measure are given in metric. Where measure is provided in imperial units, they are typically shown in parenthesis after the metric units. Magnetic signal strength is given in Teslas (T), the SI unit of flux density (or field intensity) for magnetic fields, also known as the magnetic induction. Typical signal strengths in MEG measurements are in the order of pT (picoteslas = 10^{-12}) or fT (femtoteslas = 10^{-15}).
Using MEG Processor Main Frame

Waveform viewer in the middle of main frame is used to review and edit previously collected MEG and EEG data. You can display data simultaneously as individual traces, overlaid traces, and in colored contour map format. Channels can be viewed on a trial-by-trial basis or all at once in both the time and time-frequency domains. Display settings are automatically saved and can be used to recreate a particular setup with other data of the same study type.

The waveform viewer provides various ways to mark data points and to classify trials — including marking and classifying data that meets user-defined threshold criteria or that matches a specified template pattern. The waveform viewer also allows you to analyze the data to identify and mark areas of interest for research or clinical purposes. This chapter explains how to get started with waveform viewer and shows how to use its main viewing, editing, and analyzing functions.

Environment Variables

MEG Processor has its own file format. When a file is imported at the first time, you may need to decide where to store the imported file to MEG Processor. To be safe, please do not over-write the original file.
Launching MEG Processor

Similar to many other software programs on Windows, MEG Processor can be launched by simply clicking “MEG Processor.exe” file or any short-cuts linked to it.

Importing a MEG dataset

There are several ways to import a MEG dataset:

(1) drag-and-drop: you may drag-and-drop a CTF MEG dataset on the MEG Processor program; it will automatically import the data.

(2) Open/Import File Dialog: Click the open file button (see below) or select the File->Open:

Figure 2. GUI for opening/importing MEG Dataset.
Readable Files

MEG Processor can read MEG data recorded from CTF MEG system. CTF MEG data are typically stored as many files under one directory. Following files have specific usage in the CTF MEG system.

1. *.meg: this file contains the true MEG data.
2. default.de: this file contains settings for the strip chart display, e.g., channel display sets, channel groupings, channel colors, gain, chart speed, and window layouts.
3. DataEditor.cfg: this file contains information used to configure the Print Setup dialog in the original CTF MEG data analysis system.
4. ChannelSet.cfg: this file contains channel sets. It has a list of global channel sets.
5. MEG.cfg: this file is a general configuration file for all CTF MEG applications. For DataEditor configuration, it includes a class called “Head_Motion” that specifies parameters for head motion detection.

Customizing the Layout

The MEG Processor provides templates for each type of studies, or procedure step, so that datasets of each type will display consistently and appropriately. These display settings are stored in the file. When the dataset is first imported, MEG Processor uses the default settings in this file to determine the display settings to use.

Figure 3. GUI for opening/importing MEG dataset
As shown in Figure 1, MEG Processor provides several of display set buttons that allow you to customize displays for any dataset. To switch between display sets, simply click the appropriate combo box or button or edit box. You can change any of the display settings, and your changes can be saved to the file. The next time you load the dataset, the new settings will be restored.

Displaying Channels
This section describes how to select the channels to display in the strip chart.

Figure 4. GUI for selecting dataset, trial and channels for viewing. Figure 4 shows how the dataset, trial and channels can be appropriately selected according to your needs. When you select a trial, a channel set from the combo boxes, the individual channels that belong to the set will display in the strip chart, and the status bar will update to indicate the name of the displayed channel set. You can display only one channel set at a time, although you can restrict the display of channel groups within the channel set.

Channel Types
Channel types vary among MEG systems. Here we provide the Channel Types from CTF MEG systems as an example. The following are possible channel types:

**STIM-REF**
Stimulus channel carrying trigger information.

**TIME-REF**
Time reference coming from the video channel or system clock.

**MEG-REF**
Reference magnetometer and gradiometer channels.
MEG-SENS
Sensor magnetometer and gradiometer channels.

EEG-REF
EEG bipolar sensors.

EEG-SENS
EEG unipolar sensors (typically scalp electrodes).

SAM-SENS
SAM channels derived from Synthetic Aperture Magnetometry (SAM) analysis.

VIRTUAL-SENS
Virtual channels derived from combining two or more physical channels.

ADC-REF
ADC current channels from the Head Localization Unit (HLU) for CTF MEG 2005 systems, or from the Peripheral Interface Unit (PIU) for CTF MEG 2000 and DSQ 2000 Hybrid systems.

ADC-VOLTREF
ADC volt channels from the Electronics Control Console (CTF MEG 2005 system).

DAC-REF
DAC channels from the ECC.

SUPP-REF
Supplementary channels carrying channel reset information used for cross talk (CTF MEG 2005 system).

POSITION-REF
Continuous head localization (CHL) channels carrying x, y, and z position coordinates for the localization coils as well as displacement distance information for the Na, Le, and Re channels.

FIT-ERR
CHL channels carrying fit error information for the head localization coils.

OTHER-REF
Any other type of sensor not mentioned but still valid.
Sensor and Reference Channels

In most of MEG systems, ALL SENSORS, MEG-SENS, and EEG-SENS are standard, pre-defined channels sets that are used to display MEG sensor and EEG electrode data. Reference channels (*-REF) display data collected on the various types of reference channels, and are typically used for system diagnostic purposes.

Continuous Head Localization Data

Though not all MEG systems have, modern MEG systems typically have continuous head localization channels. In CTF MEG system, the POSITION-REF channels contain Continuous Head Localization (CHL) data. Channels beginning with “HLC” display x, y, z positional data for each coil. The Na, Le, and Re channels are the vector sum of the x, y, z positional data for the nasion, left ear, and right ear head localization coils, respectively. The FIT-ERR channel type displays the fit error for the coil positions over time. Fit error is the criterion for “goodness of fit,” and provides an indication of how reliable the CHL data is. When displaying CHL channels, the software also allows you to view CHL data relative to default coil positions saved in the dataset during the head localization pre-run, so you can see the displacement from these default positions over time.

Displaying Channel Sets

A channel set is a collection of channels, such as the set of all MEG sensor channels or MEG reference channels. MEG Processor has several pre-defined channels sets, and allows you to define new ones by allocating channels to a named collection of your own. A channel can belong to more than one channel set. The Set menu in the main window menu bar displays the available channel sets for the current dataset, as shown in Figure 2.

User-defined Channel Sets

User-defined channels sets can be created from the Channel Select Dialog, which displays when you click Channel Selector button.

Displaying Channel Groups

MEG Processor also has pre-defined channel groups, which reference specific collections of channel sensors, such as the MEG Left sensors or the MEG Right channels. As with channel sets, you can also define new channel groups of your own. The Group combo box in the main window bar displays the available channel groups, as shown in Figure 4. These combo boxes allow you to control which groups of channels are displayed within a channel set. Select Show All to enable the display of all channels in the current set, regardless of their grouping. You can define new channels groups from the Group Set dialog, which displays when you select Channel Grouping from the Display Combo Boxes.
Channel Selection Dialog

A third method of selecting the channels to display is to choose them by channel set and/or individual channel name in the Channel Select dialog, shown in Figure 5. You can also define new channel sets using this dialog. To add or remove individual channels from the Selected list, highlight...
them in the Unselected or Selected lists, then use the appropriate arrow button to move them over. When you click Apply or Ok, the selected channels will display in the strip chart.

**Selecting Channel Groups**

You can overlay all traces belonging to the same channel group (e.g. left and right groups), then select them from the overlay panel by clicking on the channel group name. When you select a channel group, its individual traces may display as red lines in the overlay panel and waveform columns, and as white circles in the map, which depends on the edition you have.

**Scaling the Time Axis**

![Figure 6. Time and amplitude scale controls.](image)

This section explains how to change the time scale in the stripchart (the x-axis). MEG Processor provides the following ways to scale the time axis:

To stretch out the traces by a factor of two, click the right Time Scale arrow button in the control bar. To compress the time scale by a factor of two, click the left Time Scale arrow button. You can also set the time scale by entering a value (in milliseconds per centimeter) in the Time Scale edit field. These controls are shown in Figure 6.
Scaling the amplitude of waveforms

This section explains how to scale the amplitude scale (gain) of the waveforms (the y-axis). To double the amplitude of the channel traces, click the “Increase” gain button in the control bar. To divide the gain by a factor of two, click the “Decrease” gain button. You can also set the gain by entering a value in the “Amplitude Scale” edit field. These controls are shown in Figure 6.

Dialog for waveform display settings

The amplitude scale for displaying variety groups of waveforms can be set precisely with the Dialog for Waveform Display Settings (Figure 7). Noteworthy, the time scale for all waveforms is the same. You may set the scales by entering value in the corresponding edit field.

Define a range for viewing

To view data from a pre-defined data point, you may enter the sample index. The range of samples will be automatically decided according to the time-scale and the size of display window.

Define background and other parameters

As shown in Figure 7, you may decide the Name Bar Size and whether or not to show Grid Lines (Time-X, Amplitude-Y), Baseline, Channel Name, Data Values, Mark Lines, Trial Information and Scale Notes.

In addition, the dialog provides also the GUI for changing Text Font, Waveform color and width.

Using the Cursor to Select or Move Waveform

The cursor changes with the mode of the viewing. For example, when “Normal Select” is clicked, the mode of the Main Frame Viewer will allow you to selectively show the latency and amplitude of any
visible waveform time point. In other words, the cursor is used to select a sample (a data point in time) or a range of samples (an epoch). You can activate the cursor, i.e., display it in the overlay panel and waveform columns, by clicking the corresponding buttons in the control panel, which is shown in Figure 8.

You may move the Overlay Waveform (All Sensors) up-down or left-right by clicking the corresponding buttons in the control panel (Figure 8).

Display Whole Trial

As shown in Figure 8, you may also click the “Auto-Fit All” button to view the whole trial data. You may also click the Right Mouse Button to show the Popup menu, which allow to show whole trial by selecting the “Show Whole Trial” sub-menu. In other words, to scale the time axis to include the whole trial, right-click in the strip chart to display the waveform Popup menu, then select Show Whole Trial (see Figure 9).

Editing MEG/EEG Waveforms

Editing a dataset consists of marking points of interest in the data and classifying trials, channels, and data segments prior to analysis. This section provides an overview of these operations.
Selecting Channels in the Main Frame Viewer (Column Type)

You can display channel traces in the main frame viewer in several ways. In Column Type view, when channels are selected, their traces become red lines in the strip chart. Specifically, to select one channel, click a channel name in the waveform column.

If the contour map is visible, the selected sensors will be the red circles in the MEG (and EEG) map. To select one channel, click a sensor location on the colored MEG or EEG map.

Selecting channels is necessary prior to such operations as the following:

- classifying selected channels as “bad” using the Channel Names Popup menu
- removing all channel traces from the window except the selected ones using the Channel Names Popup menu
- adjusting the gain for the selected channels
- performing threshold detection and template matching over the selected channels
- hiding channel
- setting good channel
- setup channel

Figure 9. Popup Menu in the Main Frame Viewer.
Classifying Trials

MEG Processor provides a predefined trial classification called “Bad” to classify data containing eye blink links or other unwanted artifacts that can skew averaging and analysis results. Any trial with a classification beginning with the letters “bad” in any mixture of upper or lower case can be excluded from analysis — e.g., “Bad-Blink”. You can also define other classes to identify trials containing other types of events (see Figure 10).

Classifying Trials Manually

MEG Processor provides methods for manually classifying trials. For all the methods, the class must first be created before it can be applied, if it is not the predefined “BAD” class. To create a class,
select Edit -> Trial Classifications from the main menu to open the Class dialog. From this dialog you can enter a name for the new class and specify a color for its.

Trial-by-trial Method

1. Review each trial individually. Starting with the first trial, use the double-arrow buttons in the control bar to step through each succeeding trial until you find a trial exhibiting the characteristics you want to classify (e.g., an eye blink for a “bad” trial).

   2. Open the list of defined classes.

      Select the Edit->Trial Classification menu to open the dialog with a list of defined classes.

   3. Select the class.

      Select a class from trial classification dialog and then click apply it.

   4. (Optional) Apply another classification.

      An individual trial may belong to more than one class. To add a second classification, repeat Step 3 to mark the trial again. Selected classifications are indicated by an asterisk in the list.
Removing a Trial Classification
1. Trial-by-trial Method: In the main frame viewer, find the trial you want to reclassify by scrolling to it with the double-arrow scroll bars in the control panel, or by selecting from the Trial Combo box and specifying trial. One the trial is displayed, click right Mouse Button and uncheck the “Good Trial” or “Bad Trial”.

2. Select the Edit->Trial Classification menu to open the dialog with a list of defined classes. Click the Remove Button to remove the selected trial classification.

Classifying Channels
You can set the status of one or more selected channels to “bad” or “good” using the Main Frame Popup menu, shown in Figure 11 to set channel.

Classifying a Channel as “Bad”
1. Select the channel(s) to classify.
   In the strip chart, select the channel name(s) of the channel(s) you want to classify as “bad”. For more information, see “Selecting Channels in the Main Frame Window” on page 36.

2. Uncheck the “Good” to Set status to “bad” from the popup menu.
   Right-click over a selected channel name to display the Channel Names Popup menu, shown in Figure 11, then select the Set Good/Bad menu option.
   If the Display -> Show -> Bad Channels menu option is not selected (the default), the channel will disappear from the strip chart. If it is selected, the channel trace will be colored gray to identify it as a bad channel.

Restoring a “Bad” Channel to “Good”
1. Display bad channels.
   Select the Display > Show > Bad Channels menu option to display bad channels in the strip chart. The channel traces will be colored gray.

2. Select the channel(s) to reclassify.
   In the strip chart, select the channel name(s) of the channel(s) you want to reclassify as “good”. For more information, see “Selecting Channels in the Main Frame” on page 36.

3. Restore status to “good” from the popup menu.
   Right-click over a selected channel name to display the Channel Names Popup menu, shown in Figure 13, and then select the Set Good/Bad menu option. The channel trace will no longer be colored gray.
MEG/EEG Waveform Mark

1. Select the range of data to classify.

Using the range cursor, select the data segment you want to classify as “bad”. If it is in the segmentation mode, the bad segment will automatically add to the segment lists. If not, click the Add button will add it.

Figure 12. Dialog for MEG/EEG waveform mark.

2. Edit the segment

In the segment dialog, you may change or edit the data point range, trial number (Figure 11). To apply the changes, just click the Apply button. You may also delete any segments by selecting it in the list and then click the Delete button.
Waveform Segments

You can set as many segments of a selected range of waveform data using MEG Processor (i.e., a data segment) to “bad” or “good” using the following segmentation. Select the Edit->Trial Classification menu to open the dialog with a list of defined classes.

Classifying a Data Segment as “Bad”
1. Select the range of data to classify.

Using the range cursor, select the data segment you want to classify as “bad”. If it is in the segmentation mode, the bad segment will automatically add to the segment lists. If not, click the Add button will add it.

2. Edit the segment
In the segment dialog, you may change or edit the data point range, trial number (Figure 11). To apply the changes, just click the Apply button. You may also delete any segments by selecting it in the list and then click the Delete button.
Select-Cut
One of the very useful tools for removing bad data is select-cut function. Importantly, the data edit is reversible. Therefore, it provides the flexibility to process priceless data in timely-manner.

1. Select menu Edit->Select-Cut Settings to define how the work will be done

The “Replace with previous” option will minimize “false high-frequency signals” due to the selection and cut.

![Figure 12. Dialogs for MEG/EEG waveform select-cut.](image)

2. Select menu Edit->Select-Cut Marks to show the selections
To make life easier, the Select-Cut GUI is very similar to data segmentation. You can set as many selections of a selected range of waveform data using MEG Processor (i.e., a data segment) to “cut-list” using the following segmentation.

Figure 13. By clicking the right-mouse button and selecting the “Add and Cut Selections” popup-menu, a “piece of bad-data” can be easily selected and cut. Noteworthy, the operation is reversible.

3. Select and Cut with Popup Menu
Pattern Template Matching

1. Select the channel(s) to perform pattern-template matching.

Select one or more channels, channel groups, or channel types to mark. (For more information, see “Selecting Channels in the Main Window” on page 36.)

2. Use the range cursor to select the pattern-template data.

If you want to base the pattern-template on a waveform pattern (e.g. Spike, or spike-and-wave discharge, high-frequency bursts) in the current dataset, select it using the range cursor. Alternatively, you can open a template dataset file to use as the template.

3. Open the Pattern-Template Matching dialog.

From the Main Frame, select the Edit -> Pattern-Template Matching menu option to display the Pattern-Template dialog (see Figure 64 on page 120).

4. Specify weight and correlation values.

Enter values for the weight to apply to MEG and EEG channel types when more than one channel is selected, and for the correlation threshold (the minimum correlation required for a match). For more information about these fields, see page 124.

5. Specify names for the pattern-template matching event and scan window.

Enter the scan event to locate during template matching (the marker set name) and the scan window (the number of samples centered around this event over which template matching will be performed).

The Scan event and Scan window fields are useful when you want to locate an existing marker (the scan event), then apply the template pattern over an area of data around the marker (the scan window) to search for a similar pattern in the data. For example, you could first run the spike/spike-wave-discharge/rhythmic bursts application to mark all the events in the data, then search for the spike markers and compare the shape of the patterns in the marked samples to the template pattern.

WARNING and NOTICE

Different type of MEG/EEG channels (e.g. MEG, EEG, ADC and Trigger) may not be distinguished from each other in terms waveforms. However, because their values are typically of different orders of magnitude, unexpected results may occur if different type of channels are selected for simultaneous threshold detection. To avoid problems, only select one type of channels (MEG or EEG) at a time.

Note: Do not select MEG and EEG channels at the same time.
speed processing, you can specify a scan window around the spike markers, rather than performing template matching over the entire dataset. When a match is found, the template marker will be placed at the midpoint of the matched range.

If you do not specify these fields, the program will apply the template pattern across all data in the current trial (or entire dataset) without looking for any previous markers.

6. Specify the pattern-template data.

The template data can be a range of data in the current dataset that you select using the range cursor, or it can be the data in a template data file.

Range cursor selection: If you have not yet selected a pattern in the current dataset to use as the template, you can use the range cursor to do this while the dialog is open.

After making the selection, click the Set to range cursor button to update the dialog.

Template data file: If you want to use saved template data as the pattern instead, click the Open template data button then select the template dataset to use.

For either method, enable the Update Template (Woody Filter) option if you want to update the template as each match is made to create a running average of the original template pattern and all the matches.

7. Specify names for the marker set and trial classification.

In the Save Marker as field, enter a name for the marker set to use for marking samples that match the template pattern. If you want to classify trials that contain matched events, enter a name for the trial class and indicate whether you also want to classify the trials as BAD. For more information about the trial classification area of this dialog, see "Classify trial as" on page 126.

8. Specify the applicable channels.

If you have already selected the channels on which to apply template matching before opening the Template Matching dialog, they will be listed in the bottom pane. You can also select channels in the strip chart while this dialog is open (or change the existing channel selection). Click the Select Channels button to update the channel list in the bottom pane if you add or change the channel selection.

9. Specify the trial scope.

At the bottom of the dialog, select whether you want template matching to apply to all trials (Scan All Trials option) or only the current one (Scan Current Trial Only option).


Click the Apply button.
During the pattern-template matching process, the program will create the specified marker set (if it does not yet exist) and add markers to samples that match the template data. If you have enabled trial classification, it will also create the trial classification (if it does not yet exist) and classify trials containing the matched events. For more information on the Pattern Matching dialog, see “Template Match” on page 122.

Figure 14. Pattern-Template matched events. The management of the events is similar to marks and segments.
Threshold Detection

1. Select the channel(s) to perform threshold detection.

Select one or more channels, channel groups, or channel types to mark. (For more information, see “Selecting Channels in the Main Window” on page 36.)

**WARNING and NOTICE**

Different type of MEG/EEG channels (e.g. MEG, EEG, ADC and Trigger) may not be distinguished from each other in terms waveforms. However, because their values are typically of different orders of magnitude, unexpected results may occur if different type of channels are selected for simultaneous threshold detection. To avoid problems, only select one type of channels (MEG or EEG) at a time.

Note: Do not select MEG and EEG channels at the same time.

2. Use the range cursor to select the threshold data.

If you want to base the criteria of threshold on a pattern in the current dataset, select it using the range cursor. Alternatively, you can specify threshold values in the Threshold Detector dialog.

3. Open the Threshold Detector dialog.

From the main window, select the Analyses -> Threshold Detect menu option to display the Threshold Detector dialog (see Figure 64 on page 120).

4. Specify threshold values.

Enter values for the Amplitude Threshold, Derivative Threshold, and Dead Time, or click Get Values From Cursor to populate these fields with the values contained in the data pattern selected by the range cursor. For more information about these fields, see page 120.

5. Specify names for the threshold marker set and trial classification.

In the Save Marker as field, enter a name for the marker set to use for marking samples that meet the threshold criteria. If you want to classify trials that contain samples meeting the specified threshold criteria, enter a name for the trial class and indicate whether you also want to classify the trials as Threshold-Bad. For more information about the trial classification area of this dialog, see “Classify trial as” on page 121.
6. Specify the applicable channels.

If you have already selected the channels on which to apply threshold detection before opening the Threshold Detector dialog, they will be listed in the bottom pane. You can also select channels in the strip chart while this dialog is open (or change the existing channel selection). Click the Select Channels button to update the channel list in the bottom pane if you add or change the channel selection.

7. Specify the trial scope.

At the bottom of the dialog, select whether you want threshold detection to apply to all trials (Scan All Trials option) or only the current one (Scan Current Trial Only option).

8. Start threshold detection.

Click the Start button.

During the threshold detection process, MEG Processor will create the marker set (if it does not yet exist) and add markers to samples that meet the threshold criteria. If you have enabled trial classification, it will also create the trial classification (if it does not yet exist) and classify trials containing the threshold events. For more information on the Threshold Detector dialog, see “Threshold Detect” on page 119.
MEG/EEG Montages (CxC)

Conventionally, “Virtual” channels are used to create EEG montages, where each EEG channel may be re-referenced either to the average of all EEG channels or to a neighboring channel. The development of computer technology makes it possible to generate a Channel-cross-Channel (CxC) matrix to represent that each MEG/EEG channel is re-referenced to all other channels. By generating a CxC matrix, user can check all possible MEG/EEG Montages.

You create CxC using Wave Form Coherence Dialog, shown in Figure 13. This section illustrates some shortcut methods for defining CxC Matrix. For more information about creating CxC matrix.
In this Manual, we use “virtual channel” to describe a channel computed by two physical channel (e.g. MEG measuring channel or EEG channel). Here the computing may be an operation of addition or subtraction of two channels. On the other hand, “Virtual sensor” is typically used to describe a sensor placed in a source level, which is computed with a group of physical sensors. In other words, a “virtual sensor” is based on source localization. Here the physical sensors are usually included in the channels.
Selected Single/Multi-Wave (or Channel) Viewer

1. Open Multi-Wave Viewer.

Click menu Tool-> Multi-Wave Viewer to open the Multi-wave Viewer showing waveforms in multiple dataset and/or trials simultaneously for the selected channel. From this window you can specify the color, size of pen as well as different kinds of notes.

2. Select a channel in the Main Frame Viewer.

To make the select the channel easier, you may click on a channel in the waveform column that exhibits the pattern, peak or artifact you want to show in the Main Frame viewer and then Click the Add button, the selected channel in the Main Frame should be the default selection, which is a shortcut.

Figure 13. The Dialog for Computing Channel-Cross-Channel (CxC) Data for waveforms.
## Index

**E**
- Electroencephalography (EEG), 5

**F**
- femtoteslas, 6

**M**
- Magnetic source imaging (MSI), 5
- Magnetoencephalography (MEG), 5
- Main Frame, 6

**P**
- picoteslas, 6

**T**
- Teslas (T), 6